QuickFix. После обновления Veeam Backup & Replication до версии 11, не обновляется AHV прокси до версии 2.1

Если после обновления VBR до версии 11, прокси сервера для AHV находятся в разделе Out Of Date, а при попытке обновления появляется ошибка следующего характера:

Failed to upgrade host components. Error: ‘Failed to upgrade Proxy – AHV Proxy upgrade failed. Error: Updates are not found.’

Стоило читать документацию перед обновлением 🙂 . Процедура обновления под катом.

Итак, после обновления VBR мы находимся в следующем состоянии:

Затем запускаем процедуру обновления AHV Proxy до версии 2.1:

И получаем ошибку:

Failed to upgrade host components. Error: ‘Failed to upgrade Proxy – AHV Proxy upgrade failed. Error: Updates are not found. Please Contact Veeam customer support’

Хорошая новость: обращаться в техническую поддержку не обязательно.

Если обратиться к документации по Veeam Backup for Nutanix AHV 2.1 можно обнаружить раздел посвященный обновлению прокси, который выводит на kb4150, в которой сказано следующее:

This occurs because the existing repository key for versions of products related to this article expired on April 16, 2021 (2021-04-16). Newer versions of the listed products are able to update the repository key automatically. For older versions, such as those listed on this article, users must manually remove the expired key and install the updated key.

Если коротко: ключи для репозиториев с программным обеспечением истекли. Скачайте и поставьте новые.

Для замены ключей нам необходимо подключиться к консоли нашего AHV прокси. Доступ по SSH к нему закрыт, поэтому провести операции необходимо из Prism Element, либо Prism Central, подключившись напрямую к виртуальной машине:

Доступ в систему осуществляется с помощью пользователя veeam и пароля, заданного для данного прокси на этапе его конфигурации (по умолчанию это veeam/veeam). Эта же связка используется для входа в web-интерфейс прокси.

В консоли осталось выполнить 3 простых действия.

  1. Удалить старый ключ:

sudo rm /etc/apt/trusted.gpg.d/veeam.gpg

  1. Скачать новый ключ veeam.gpg и поместить его в /etc/apt/trusted.gpg.d/:

sudo wget https://repository.veeam.com/keys/veeam.gpg -O /etc/apt/trusted.gpg.d/veeam.gpg

  1. Затем обновить базу данных пакетов:

sudo apt-get update

Единственная проблема, которая может возникнуть на всем этапе – отсутствие доступа в интернет у AHV прокси.

В этом случае можно задействовать интернет-прокси, если таковой имеется:

export http_proxy=http://proxy_ip:proxy_port
export https_proxy=http://proxy_ip:proxy_port

Затем скачать gpg ключ куда-нибудь в /tmp и уже потом скопировать в /etc/apt/trusted.gpg.d/veeam.gpg.

Перед запуском apt также понадобится выполнить настройки интернет-прокси, создав конфигурационный файл:

sudo vi /etc/apt/apt.conf.d/proxy.conf
Acquire::http::Proxy "http://proxy_ip:proxy_port";
Acquire::https::Proxy "http://proxy_ip:proxy_port";

И уже затем выполнять sudo apt-get update.

Теперь возвращаемся в консоль VBR и обновляем AHV прокси еще раз. Все должно быть в порядке:

Прокси обновлен до версии 2.1:

Leave a Reply

Your email address will not be published. Required fields are marked *